Device Trust macOS Compatibility
The table below shows the macOS versions compatible with Device Trust. It is crucial that you check the compatibility table before upgrading the macOS. Upgrading the macOS to a version unsupported by Device Trust can result in unpredictable behavior, and system lock out.
macOS Version Supported Notes
macOS Monterey 12.2 Yes
macOS Monterey 12.1 Yes
macOS Monterey 12.0 No Will lock machine out. Need to disable Device Trust before upgrading which will leave your system vulnerable.
macOS Big Sur 11.6.3 Yes
macOS Catalina 10.15.7 Yes